Untitled
raw download clone
TEXT
views 14
,
size 7994 b
lab2:
Router> User Mode "enabel"

Router# Privileged EXEC mode "configure tirmenal"
Router# show ip route
Router# show ipv6 route
Router# show ip protocols 
Router# show ipv6 protocols
Router# show running-config
Router# show ip dhcp binding
Router# show ip interface brief
Router# copy running-config startup-config
Router# reload
Router# erase stratup-config
Router# reload
Router# show vlan 
Router# show interfaces interface_name switchport
Router# show interfaces trunk
Router# show vlan command
Router# show ip nat translations
Router# show ip nat statistics
 


Router(config)# Global Configuration mode
___
1.Host Name: 
Router(config)# hostname  ******

2.Login banners:
Router(config)# banner motd  #your statment#

3.Prevent translation for hostname: 
Router(config)# no ip domain-lookup

4.Configuring router passwords: 
Router(config)# enable password yourpassword
Router(config)# enable secret yourpassword

Router(config)# line console 0 
Router(config-line)# password  yourpassword
Router(config-line)# login

Router(config)# line  vty 0 4
Router(config-line)# password  yourpassword
Router(config-line)# login


Router(config)# service password-encryption

5.Configuring Ethernet interfaces
Router(config)#interface G0/1  
Router(config-if)# description descriptive-text 
Router(config-if)# ip address ipaddress  subnetmask  
Router(config-if)# no shutdown
___________________________________________________
lab3:
Router(config-if)# clock rate 64000(after add serial port)

Configure Static Route:  المقابل IP الشبكة المربوطة بالراوتر تكون الشبكة المقابله لها هي الريموت عن طريق 
Router(config)# ip route network-address subnet-mask IP-address(next-hop)
Router(config)#ip route  (192.168.5.0)  255.255.255.0  200.10.10.2(مكان ما بخرج مقابل ما بدخل) 
Router(config)# ip route network-address subnet-mask exit-interface
Router(config)#ip route  (192.168.5.0)  255.255.255.0   s0/0/0

Configure a Default Static Route:
Router(config)# ip route 0.0.0.0 0.0.0.0 IP-address (for interface المقابل للرواتر)
Router(config)# ip route 0.0.0.0 0.0.0.0 exit-interface
_____________________________________________________________________
lab4:
Configure RIPv2:
Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# no auto-summary
Router(config-router)# network network-address(directly-network)
Router(config-router)# passive-interface interface-name(g0/1 to end device)

Configure OSPF: all network in eche side for router
Router(config)# router ospf process-ID
Router(config-router)# network network-address wildcard-mask area  0
Router(config-router)# passive-interface interface-name
_____________________________________________________________________
lab5:
DHCP:
Router(config)# ip dhcp excluded-address FirstIP LastIP
Router(config)# ip dhcp pool POOL-NAME
Router(dhcp-config)# network NETWORK-ID SUBNET-MASK
Router(dhcp-config)# default-router IP-Address(default getway)
Router(dhcp-config)# dns-server IP-Address(optional)

FTP:
Upload a File to the FTP Server:
dir
ftp ip_address_of_Server1
put myfile.txt’
quit
Download a File from the FTP Server:
ftp ip_address_of_Server
get myfile.txt
_______________________________________________________________________
lab6:
Configure IPv6 Addressing on the Routers:
Router(config)# ipv6 unicast-routing
Router(config-if)# interface #
Router(config-if)# ipv6 address 2001:DB8:1:1::1/64
Router(config-if)#no shutdown
Router(config-if)# ipv6 address FE80::1 link-local

Configure IPv6 addressing on Serial interfaces:
Router(config)# ipv6 address 2001:DB8:1:2::1/126
Router(config)# ipv6 address FE80::1 link-local

OSPFv3 routing:
Router(config)# ipv6 router ospf process-id
Router(config)# router-id router_id(0.0.0.1)
Router(config)# exit
Router(config)#interface #
Router(config)# ipv6 ospf process_id area 0
Router(config)# passive-interface interface_id(end device)
_______________________________________________________________________
lab7:
Configuring VLANs:
switch(config)# vlan vlan-id
switch(config)# name vlan-name
switch(config)# exit

Assign ports vlan:
switch(config)# interface G0/1
switch(config)# switchport mode access
switch(config)#switchport access vlan vlan-id
switch(config)# exit

switchport mode trunk: between switch
switch(config)# interface G0/1
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan vlan-list(10,20,30)
switch(config-if)# switchport trunk native vlan vlan-id
switch(config-if)# exit

Configure the Switch Virtual Interface: manegment vlan
Switch# configure terminal
Switch(config)# interface  vlan   10
Switch(config-if)# ip address vlan-IPaddress vlan-mask
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# ip default-gateway ip

Configure the VTY lines on Switch  
Switch(config)# line  vty  0  4
Switch(config-line)# password XpasswordX
Switch(config-line)# login
______________________________________________________________
lab8:
Configuring VLANs in Router(sub-interface):
Router(config)# interface G0/1.10
Router(config-subif)# encapsulation  dot1Q  10 (#ofVLAN)
Router(config-subif)# ip address  vlan-ipaddress vlan-mask
Router(config-subif)#exit
Router(config)#interface g0/1
Router(config)# no shutdown
______________________________________________________________
lab9:
Static NAT (ip nat inside source static)Edge router:Mapping
Edge(config)# ip nat inside source static Private-Address(local) Public-Address(global)

configure the Edge’s router interfaces as nat inside and nat outside:
Edge(config)# interface Se0/0/0 
Edge(config-if)# ip nat inside 
Edge(config)# interface Se0/0/1 
Edge(config-if)# ip nat outside(public network)
*******************************************************************************
Dynamic NAT: many to many
Edge(config)# ip nat pool pool-name  First-IP_Last-IP(global IP range)  netmask  Subnet-mask

Configure a standard ACL:
Edge(config)# access-list list-identifier-number permit IP-address(local IP after router 192.168.0.0) wildcard

Bind the ACL to the pool: manage NAT with ACL
Edge(config)# ip nat inside source list list-identifier-number pool pool-name
Edge(config)# ip nat inside source list 1 pool NAT-POOL1(exampel)

Identify which interfaces are inside&outside:
Edge(config)# interface Se0/0/0 
Edge(config-if)# ip nat inside 
Edge(config)# interface Se0/0/1 
Edge(config-if)# ip nat outside(public network)

Edge# clear ip nat translations *
**********************************************************************************************
Configure PAT to use a single IP address(Configure a standard ACL):
Edge(config)# access-list 1 permit IP-address(local IP after router 192.168.0.0) MASK

Bind the ACL to the single IP address:
Edge(config)# ip nat inside source list list-identifier-number interface interface-name overload
Edge(config)# ip nat inside source list 1 interface Se0/0/1(outside) overload (exampel)

Identify which interfaces are inside&outside:
Edge(config)# interface Se0/0/0 
Edge(config-if)# ip nat inside 
Edge(config)# interface Se0/0/1 
Edge(config-if)# ip nat outside
Edge# clear ip nat translations *
***********************************************************************************************
configure PAT for a dynamic NAT address pool:
Edge(config)# ip nat pool NAT-POOL1 (Global ip 130.60.30.4 130.60.30.7 range of pool) netmask 255.255.255.192
Edge(config)# access-list 1 permit 192.168.0.0 0.0.255.255
Edge(config)# ip nat inside source list 1 pool NAT-POOL1 overload

Identify which interfaces are inside&outside:
Edge(config)# interface Se0/0/0
Edge(config-if)# ip nat inside
Edge(config-if)# interface Se0/0/1
Edge(config-if)# ip nat outside (public)
Edge# clear ip nat translations *
close fullscreen
Login or Register to edit or fork this paste. It's free.