Untitled
raw download clone
TEXT
views 13
,
size 7058 b
lab2:
Router> User Mode "enabel"

Router# Privileged EXEC mode "configure tirmenal"
Router# show ip route
Router# show ipv6 route
Router# show ip protocols 
Router# show ipv6 protocols
Router# show running-config
Router# show ip dhcp binding
Router# show ip interface brief
Router# copy running-config startup-config
Router# reload
Router# erase stratup-config
Router# reload
Router# show vlan 
Router# show interfaces interface_name switchport
Router# show interfaces trunk
Router# show vlan command
Router# show ip nat translations
Router# show ip nat statistics
 


Router(config)# Global Configuration mode
___
1.Host Name: 
Router(config)# hostname  ******

2.Login banners:
Router(config)# banner motd  #your statment#

3.Prevent translation for hostname: 
Router(config)# no ip domain-lookup

4.Configuring router passwords: 
Router(config)# enable password yourpassword
Router(config)# enable secret yourpassword

Router(config)# line console 0 
Router(config-line)# password  yourpassword
Router(config-line)# login

Router(config)# line  vty 0 4
Router(config-line)# password  yourpassword
Router(config-line)# login


Router(config)# service password-encryption

5.Configuring Ethernet interfaces
Router(config)#interface G0/1  
Router(config-if)# description descriptive-text 
Router(config-if)#ip address ipaddress  subnetmask  
Router(config-if)#no shutdown
___________________________________________________
lab3:
Configure Static Route:
Router(config)# ip route network-address subnet-mask IP-address
Router(config)# ip route network-address subnet-mask exit-interface

Configure a Default Static Route:
Router(config)# ip route 0.0.0.0 0.0.0.0 IP-address
Router(config)# ip route 0.0.0.0 0.0.0.0 exit-interface
_____________________________________________________________________
lab4:
Configure RIPv2:
Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# no auto-summary
Router(config-router)# network network address
Router(config-router)# passive-interface interface-name

Configure OSPF:
Router(config)# router ospf process-ID
Router(config-router)# network network-address wildcard-mask area  0
Router(config-router)# passive-interface interface-name
_____________________________________________________________________
lab5:
DHCP:
Router(config)# ip dhcp excluded-address FirstIP LastIP
Router(config)# ip dhcp pool POOL-NAME
Router(dhcp-config)# network NETWORK-ID SUBNET-MASK
Router(dhcp-config)# dns-server IP-Address
Router(dhcp-config)# default-router IP-Address

FTP:
Upload a File to the FTP Server:
dir
ftp ip_address_of_Server1
put myfile.txt’
quit
Download a File from the FTP Server:
ftp ip_address_of_Server
get myfile.txt
_______________________________________________________________________
lab6:
Configure IPv6 Addressing on the Routers:
Router(config)# ipv6 unicast-routing
Router(config)# ipv6 address 2001:DB8:1:1::1/64
Router(config)# ipv6 address FE80::1 link-local

Configure IPv6 addressing on Serial interfaces:
Router(config)# ipv6 address 2001:DB8:1:2::1/126
Router(config)# ipv6 address FE80::1 link-local

OSPFv3 routing:
Router(config)# ipv6 router ospf process-id
Router(config)# router-id router_id
Router(config)# ipv6 ospf process_id area 0
Router(config)# passive-interface interface_id
_______________________________________________________________________
lab7:
Configuring VLANs:
switch(config)# vlan vlan-id
switch(config)# name vlan-name
switch(config)# end

Assign ports vlan:
switch(config)# interface G0/1
switch(config)# switchport mode access
switch(config)#switchport access vlan vlan-id
switch(config)# end

switchport mode trunk:
switch(config)# interface G0/1
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk native vlan vlan-id
switch(config-if)# switchport trunk allowed vlan vlan-list
switch(config-if)# end

Configure the Switch Virtual Interface:
Switch# configure terminal
Switch(config)# interface  vlan   10
Switch(config-if)# ip address vlan-IPaddress vlan-mask
Switch(config-if)# no shutdown
Switch(config-if)# exit
Switch(config)# ip default-gateway ip

Configure the VTY lines on Switch  
Switch(config)# line  vty  0  4
Switch(config-line)# password XpasswordX
Switch(config-line)# login
______________________________________________________________
lab8:
Configuring VLANs in Router(sub-interface):
Router(config)# interface G0/1.10
Router(config-subif)# encapsulation  dot1Q  10
Router(config-subif)# ip address  vlan-ipaddress vlan-mask
______________________________________________________________
lab9:
Static NAT (ip nat inside source static)Edge router:
Edge(config)# ip nat inside source static Private-Address Public-Address

configure the Edge’s router interfaces as nat inside and nat outside:
Edge(config)# interface Se0/0/0 
Edge(config-if)# ip nat inside 
Edge(config)# interface Se0/0/1 
Edge(config-if)# ip nat outside
*******************************************************************************
Dynamic NAT:
Edge(config)# ip nat pool pool-name  First-IP  Last-IP  netmask  Subnet-mask
*******************************************************************************
Configure a standard ACL:
Edge(config)# access-list list-identifier-number permit IP-address wildcard
Edge(config)# access-list 1 permit 192.168.0.0 _ 0.0.255.255(exampel)

Bind the ACL to the pool:
Edge(config)# ip nat inside source list list-identifier-number pool pool-name
Edge(config)# ip nat inside source list 1 pool NAT-POOL1(exampel)

Identify which interfaces are inside&outside:
Edge(config)# interface Se0/0/0 
Edge(config-if)# ip nat inside 
Edge(config)# interface Se0/0/1 
Edge(config-if)# ip nat outside

Edge# clear ip nat translations *
**********************************************************************************************
Configure PAT to use a single IP address(Configure a standard ACL):
Edge(config)# access-list 1 permit 192.168.0.0 0.0.255.255

Bind the ACL to the single IP address:
Edge(config)# ip nat inside source list list-identifier-number interface interface-name overload
Edge(config)# ip nat inside source list 1 interface Se0/0/1 overload (exampel)

Identify which interfaces are inside&outside:
Edge(config)# interface Se0/0/0 
Edge(config-if)# ip nat inside 
Edge(config)# interface Se0/0/1 
Edge(config-if)# ip nat outside
***********************************************************************************************
configure PAT for a dynamic NAT address pool:
Edge(config)# ip nat pool NAT-POOL1 130.60.30.4 130.60.30.7 netmask 255.255.255.192
Edge(config)# access-list 1 permit 192.168.0.0 0.0.255.255
Edge(config)# ip nat inside source list 1 pool NAT-POOL1 overload

Identify which interfaces are inside&outside:
Edge(config)# interface Se0/0/0
Edge(config-if)# ip nat inside
Edge(config-if)# interface Se0/0/1
Edge(config-if)# ip nat outside
close fullscreen
Login or Register to edit or fork this paste. It's free.